1С-Предприятие 8.0. Практическое пособие разработчика

         

Объекты встроенного языка для работы с константами:


*Заливкой выделен объект манипулирования данными

Узнай больше!

Про основные виды объектов встроенного языка можно прочитать в главе "Виды объектов встроенного языка, предназначенные для работы с данными прикладных объектов конфигурации" на странице 551.

КонстантыНабор – предоставляет возможность проведения операций чтения и записи сразу для группы констант, в частном случае – для всех констант. Также используется в форме констант для хранения, записи и считывания констант.

КонстантаМенеджерЗначения<имя> – используется для доступа к константе. Любая запись константы (интерактивно в форме, объекты КонстантыНабор и КонстантаМенеджер.<имя>) создает объект этого типа и производит запись с его помощью, что обеспечивает вызов модуля и обработчиков событий этого объекта. [565]

//  Константы

//Пример: Открыть основную форму констант

Форма = Константы.ПолучитьФорму();

Форма.Открыть();

//  .<имя константы>

//  [<имя константы>]

//  Для Каждого ... Из ... Цикл ... КонецЦикла;

//Пример: Прочитать значение константы

Результат = Константы.ПрефиксНумерации.Получить();

Сообщить("Значение константы ПрефиксНумерации = "+Результат);

//Пример: Установить значение константы "ПрефиксНумерации" равным "ЦБ"

Константы["ПрефиксНумерации"].Установить("ЦБ");

Сообщить("Новое значение = "+Константы["ПрефиксНумерации"].Получить());

//Пример: Очистить значения всех констант

Для Каждого ОчереднаяКонстанта Из Константы Цикл

   ОчереднаяКонстанта.Установить(Неопределено);

КонецЦикла;

//  СоздатьНабор()

//Пример: Установить новые значения нескольких констант

Набор = Константы.СоздатьНабор("Руководитель, Бухгалтер");

Набор.Руководитель = "Николаев Денис Павлович";




Набор.Бухгалтер = "Николаева Людмила Сергеевна";

Набор.Записать(); [566]

















//  СоздатьМенеджерЗначения()





//Пример: Вывести значения всех констант, существующих в конфигурации

Для Каждого ОчереднаяКонстанта Из Константы Цикл

   ИмяКонст = ОчереднаяКонстанта.СоздатьМенеджерЗначения().Метаданные().Имя;

   ЗначениеКонст = ОчереднаяКонстанта.Получить();

   Сообщить("Константа "+ИмяКонст+" = "+ЗначениеКонст);

КонецЦикла; [567]




Содержание раздела







Forekc.ru
Рефераты, дипломы, курсовые, выпускные и квалификационные работы, диссертации, учебники, учебные пособия, лекции, методические пособия и рекомендации, программы и курсы обучения, публикации из профильных изданий