1С-Предприятие 8.0. Практическое пособие разработчика


Объекты встроенного языка для работы со справочниками


*Заливкой выделен объект манипулирования данными

 

 

Узнай больше!

Про основные виды объектов встроенного языка можно прочитать в главе "Виды объектов встроенного языка, предназначенные для работы с данными прикладных объектов конфигурации" на странице 551. [570]

 

 

 

 

//  Справочники

//Пример: Вывести все типы ссылок на элементы справочников, существующие

//в конфигурации

Массив = Справочники.ТипВсеСсылки().Типы();

Для Каждого ОчереднойТип из Массив Цикл

   Сообщить(ОчереднойТип);

КонецЦикла;

 

//  .<имя справочника>

//  [<имя справочника>]

//  Для Каждого ... Из ... Цикл ... КонецЦикла;

//Пример: Создать новую группу справочника Номенклатура

НоваяГруппа = Справочники.Номенклатура.СоздатьГруппу();

НоваяГруппа.Наименование = "Моя новая группа";

НоваяГруппа.Записать();

 

//Пример: Открыть форму выбора справочника Номенклатура

Форма = Справочники["Номенклатура"].ПолучитьФормуВыбора();

Форма.Открыть(); [571]

 

//  НайтиПоКоду()

//  НайтиПоНаименованию()

//  НайтиПоРеквизиту()

//  ПустаяСсылка()

//  ПолучитьСсылку()

//  .<имя предопределенного элемента справочника>

//Пример: Проверить, помечен ли на удаление элемент справочника Номенклатура

//c кодом 13

Если Справочники.Номенклатура.НайтиПоКоду(13).ПометкаУдаления Тогда

   Сообщить("Элемент с кодом 13 помечен на удаление");

КонецЕсли;

 

//Пример: Является ли элемент справочника Номенклатура с наименованием

//"Услуги" группой

Если Справочники.Номенклатура.НайтиПоНаименованию("Услуги", Истина).ЭтоГруппа Тогда

   Сообщить("Элемент Услуги является группой");

КонецЕсли;

 

//Пример: Проверить, что для всех элементов задан вид номенклатуры

ПустаяСсылкаПеречисления = Перечисления.ВидыНоменклатуры.ПустаяСсылка();




Начало  Назад  Вперед



Книжный магазин