1С-Предприятие 8.0. Практическое пособие разработчика


Объекты встроенного языка для работы со справочниками - часть 3


   КонецЕсли;

КонецПроцедуры

 

//  ПолучитьОбъект()

//  Скопировать()

//Пример: Изменить наименование элемента справочника

Элемент = Справочники.Номенклатура.НайтиПоКоду(10).ПолучитьОбъект();

Элемент.Наименование = "Мое новое наименование";

Элемент.Записать();

 

//Пример: Заполнить справочник тестовыми данными

Элемент = Справочники.Номенклатура.СоздатьЭлемент();

Элемент.Наименование = "Тестовый элемент";

Элемент.Записать();

Для сч_к = 1 по 1000 Цикл

   НовыйЭлемент = Элемент.Скопировать();

   НовыйЭлемент.Записать();

КонецЦикла; [574]

 

//  Ссылка

//Пример: Заполнить табличную часть документа ПриходнаяНакладная всеми

//элементами из указанной группы справочника Номенклатура

Выборка = Справочники.Номенклатура.ВыбратьИерархически(ПолеВвода1);

Пока Выборка.Следующий() Цикл

   СсылкаНаНоменклатуру = Выборка.Ссылка;

   Если СсылкаНаНоменклатуру.ЭтоГруппа Тогда

       Продолжить;

   КонецЕсли;

   НоваяСтрока = Материалы.Добавить();

   НоваяСтрока.Материал = СсылкаНаНоменклатуру;

КонецЦикла;

 

//  ПолучитьОбъект()

//Пример: пометить все элементы неиерархического справочника на удаление

Выборка = Справочники.Клиенты.Выбрать();

Пока Выборка.Следующий() Цикл

   Выборка.ПолучитьОбъект().УстановитьПометкуУдаления(Истина);

КонецЦикла; [575]

 




Начало  Назад  Вперед



Книжный магазин