1С-Предприятие 8.0. Практическое пособие разработчика
508 Resource Limit Is Reached

Resource Limit Is Reached

The website is temporarily unable to service your request as it exceeded resource limit. Please try again later.

Объекты встроенного языка для работы со справочниками - часть 2


Если Не Справочники.Номенклатура.НайтиПоРеквизиту("ВидНоменклатуры", ПустаяСсылкаПеречисления).Пустая() Тогда

   Сообщить("Есть элементы для которых не задан вид номенклатуры");

КонецЕсли;

 

//Пример: Передать пустую ссылку в параметр метода

Выборка = Справочники.Номенклатура.Выбрать(Справочники.Номенклатура.ПустаяСсылка()); [572]

 

//  Выбрать()

//  ВыбратьИерархически()

//Пример: Вывести список элементов, расположенных в корне справочника

Выборка = Справочники.Номенклатура.Выбрать(Справочники.Номенклатура.ПустаяСсылка());

Пока Выборка.Следующий() Цикл

   Если Не Выборка.ЭтоГруппа Тогда

       Сообщить(Выборка);

   КонецЕсли;

КонецЦикла;

 

//Пример: Удалить все элементы иерархического справочника

Выборка = Справочники.Номенклатура.ВыбратьИерархически();

Пока Выборка.Следующий() Цикл

   Выборка.ПолучитьОбъект().Удалить();

КонецЦикла;

 

//  СоздатьГруппу()

//  СоздатьЭлемент()

//Пример: Создать новый элемент справочника Сотрудники

НовыйЭлемент = Справочники.Сотрудники.СоздатьЭлемент();

НовыйЭлемент.Наименование = "Смирнов Андрей Анатольевич";

//Заполнить табличную часть

НоваяСтрокаТабличнойЧасти = НовыйЭлемент.ТрудоваяДеятельность.Добавить();

НоваяСтрокаТабличнойЧасти.Организация = "OOO НТЦ";

НоваяСтрокаТабличнойЧасти.НачалоРаботы = Дата(2003,05,01);

НоваяСтрокаТабличнойЧасти.ОкончаниеРаботы = Дата(2003,12,31);

НоваяСтрокаТабличнойЧасти.Должность = "Программист";

НовыйЭлемент.Записать(); [573]

 

//  Владелец

//  Родитель

//  Ссылка

//Пример: запретить изменение подчиненных элементов, если у владельца

//установлено соответствующее свойство "ИзмененияЗапрещены"

//в модуле формы элемента справочника

Процедура ПередЗаписью(Отказ)

   Если Владелец.ИзмененияЗапрещены Тогда

       Отказ = Истина;




Начало  Назад  Вперед


508 Resource Limit Is Reached

Resource Limit Is Reached

The website is temporarily unable to service your request as it exceeded resource limit. Please try again later.