1С-Предприятие 8.0. Практическое пособие разработчика


Объекты встроенного языка для работы с регистрами накопления - часть 2


 

//  СоздатьНаборЗаписей()

//Пример: Получить движения документа

НужныйДокумент = Документы.ПриходнаяНакладная.НайтиПоНомеру(4);

Движения = РегистрыНакопления.ОстаткиМатериалов.СоздатьНаборЗаписей();

Движения.Отбор.Регистратор.Значение = НужныйДокумент;

Движения.Прочитать();

 

//  Выбрать()

//  ВыбратьПоРегистратору()

//Пример: Выбрать все записи регистра ОстаткиМатериалов за текущий месяц

Выборка = РегистрыНакопления.ОстаткиМатериалов.Выбрать(НачалоМесяца(ТекущаяДата()), КонецМесяца(ТекущаяДата()));

Пока Выборка.Следующий() Цикл

   Сообщить("Регистратор: " + Выборка.Регистратор + " Материал: " + Выборка.Материал + " Кол-во: " + Выборка.Количество);

КонецЦикла;

 

//  [<индекс элемента коллекции>]

//  Для Каждого ... Из ... Цикл ... КонецЦикла;

//Пример: Получить движения документа

НужныйДокумент = Документы.ПриходнаяНакладная.НайтиПоНомеру(4);

Движения = РегистрыНакопления.ОстаткиМатериалов.СоздатьНаборЗаписей();

Движения.Отбор.Регистратор.Значение = НужныйДокумент;

Движения.Прочитать();

Для Каждого ОчередноеДвижение Из Движения Цикл

   //алгоритм обработки движений

КонецЦикла; [601]

 




Начало  Назад  Вперед



Книжный магазин