1С-Предприятие 8.0. Практическое пособие разработчика


Объекты встроенного языка для работы с регистрами сведений - часть 2


СтруктураКлючевыхПолей = Новый Структура;

СтруктураКлючевыхПолей.Вставить("Период", Дата("20040331000000"));

СтруктураКлючевыхПолей.Вставить("Номенклатура", Справочники.Номенклатура.НайтиПоКоду("0000006"));

ЭлементыФормы.ТабличноеПоле1.ТекущаяСтрока = РегистрыСведений.Цены.СоздатьКлючЗаписи(СтруктураКлючевыхПолей);

 

//  СоздатьНаборЗаписей()

//Пример: Показать номенклатуру, цена на которую была установлена в заданную

//дату и время

Набор = РегистрыСведений.Цены.СоздатьНаборЗаписей();

Набор.Отбор.Период.Установить(ЗаданнаяДата, Истина);

Набор.Прочитать();

Для Каждого ОчереднаяЗапись Из Набор Цикл

   Сообщить("Номенклатура = "+ОчереднаяЗапись.Номенклатура+", цена = "+ОчереднаяЗапись.Цена);

КонецЦикла;

 

//  СоздатьМенеджерЗаписи()

//Пример: Добавить новое значение цены в регистр Цены

Запись = РегистрыСведений.Цены.СоздатьМенеджерЗаписи();

Запись.Период = ТекущаяДата();

Запись.Номенклатура = Справочники.Номенклатура.НайтиПоКоду("0000005");

Запись.Цена = 568;

Запись.Записать(); [595]

 

//  [<индекс элемента коллекции>]

//  Для ... По ... Цикл ... КонецЦикла;

//Пример: Показать номенклатуру, цена на которую была установлена в заданную

//дату и время

Набор = РегистрыСведений.Цены.СоздатьНаборЗаписей();

Набор.Отбор.Период.Установить(ЗаданнаяДата, Истина);

Набор.Прочитать();

Для сч_к = 0 По Набор.Количество() - 1 Цикл

   Сообщить("Номенклатура = "+Набор[сч_к].Номенклатура+", цена = "+Набор[сч_к].Цена);

КонецЦикла;

 

//  ПолучитьМенеджерЗаписи()

//Пример: Удалить все записи регистра сведений за текущий месяц

Выборка = РегистрыСведений.Цены.Выбрать(НачалоМесяца(ТекущаяДата()), КонецМесяца(ТекущаяДата()));

Пока Выборка.Следующий() цикл

   Выборка.ПолучитьМенеджерЗаписи().Удалить();

КонецЦикла;

 




Начало  Назад  Вперед



Книжный магазин