1С-Предприятие 8.0. Практическое пособие разработчика


Объекты встроенного языка для работы с перечислениями:


 

 

 

Узнай больше!

Про основные виды объектов встроенного языка можно прочитать в главе "Виды объектов встроенного языка, предназначенные для работы с данными прикладных объектов конфигурации" на странице 551.

 

 

 

 

Использование объектов:

//  Перечисления

//Пример: Открыть форму списка перечисления

Форма = Перечисления.ВидыНоменклатуры.ПолучитьФормуСписка();

Форма.Открыть();[584]

 

//  .<имя перечисления>

//  [<имя перечисления >]

//  Для Каждого ... Из ... Цикл ... КонецЦикла;

//Пример: Открыть форму выбора перечисления

Форма = Перечисления.ВидыНоменклатуры.ПолучитьФормуВыбора();

Форма.Открыть();

 

//    .<имя значения перечисления>

//    [<имя значения перечисления>]

//    [<индекс элемента коллекции>]

//    Для Каждого... Из ... Цикл ... КонецЦикла;

//    ПустаяСсылка()

//Пример: Получить пустую ссылку на значение перечисления

...

ПустаяСсылкаПеречисления = Перечисления.ВидыНоменклатуры.ПустаяСсылка();

Если ТекущаяНоменклатура.ВидНоменклатуры = ПустаяСсылкаПеречисления Тогда

   //предложить заполнение вида номенклатуры

   ...

КонецЕсли;

...[585]

 


Предыдущий параграф

Следующая страница




Начало  Назад  Вперед



Книжный магазин