1С-Предприятие 8.0. Практическое пособие разработчика


Вычисляемые колонки в списках


Необходимость вывода произвольных данных в колонках списка возникает, когда вместе с элементом списка нужно отобразить некоторую вычисляемую информацию.

Мы рассмотрим эту ситуацию на примере отображения актуальной цены в списке справочника "Номенклатура".

Откроем в конфигураторе форму списка справочника "Номенклатура" (или, если ее нет, создадим основную форму списка). Воспользуемся контекстным меню правой кнопки мыши и добавим в табличное поле колонку с именем и текстом шапки "Цена":

В табличное поле списка справочника Номенклатура добавим колонку Цена...

Создадим обработчик события табличного поля "При выводе строки", и добавим в него следующий текст:

Процедура СправочникСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

   //для элементов отобразим цену и ...

   Если Не ДанныеСтроки.ЭтоГруппа Тогда

       ОтборНоменклатуры = Новый Структура;

       ОтборНоменклатуры.Вставить("Номенклатура", ДанныеСтроки.Ссылка); [524]

       ОформлениеСтроки.Ячейки.Цена.ОтображатьТекст = Истина;

       АктуальнаяЦена = РегистрыСведений.Цены.ПолучитьПоследнее(, ОтборНоменклатуры).Цена;

       ОформлениеСтроки.Ячейки.Цена.Текст = АктуальнаяЦена;

       //низкие цены выделим другим цветом

       Если АктуальнаяЦена < 500 Тогда

           ОформлениеСтроки.Ячейки.Цена.ЦветТекста = WEBЦвета.Васильковый;

       КонецЕсли;

   КонецЕсли;

КонецПроцедуры

 

Обработчик события табличного поля "При выводе строки" передает три параметра: "Элемент" – само табличное поле, для которого было вызвано это событие, "ОформлениеСтроки" – объект, содержащий оформление выводимой строки табличного поля и "ДанныеСтроки" – элемент выборки справочника "Номенклатура", отображаемый в выводимой строке.




Начало  Назад  Вперед