1С-Предприятие 8.0. Практическое пособие разработчика


Подбор с использованием множественного выбора


Еще одним способом организации подбора является возможность использования свойства формы "Множественный выбор". Это свойство разрешает множественный выбор в табличных полях формы. В этом случае в форму документа будет возвращен не элемент справочника, а массив элементов, выбранных в табличном поле формы справочника. [490]

В форме документа "ПриходнаяНакладная" внесем в обработчик события нажатия кнопки "Подбор" следующие изменения:

Процедура КоманднаяПанельМатериалыПодбор(Кнопка)

ФормаПодбора = Справочники.Номенклатура.ПолучитьФормуСписка( ,ЭлементыФормы.Материалы);

   ФормаПодбора.РежимВыбора = Истина;

  //ФормаПодбора.ЗакрыватьПриВыборе = Ложь;

   ФормаПодбора.МножественныйВыбор = Истина;

   ФормаПодбора.Открыть();

КонецПроцедуры

 

В обработчик события "Обработка выбора" добавим обход массива переданных элементов:

Процедура МатериалыОбработкаВыбора(Элемент, РезультатВыбора, СтандартнаяОбработка)

   Для СчетчикЦикла = 0 по РезультатВыбора.ВГраница() Цикл

       НоваяСтрока = Материалы.Добавить();

       НоваяСтрока.Материал = РезультатВыбора[СчетчикЦикла];

   КонецЦикла;

КонецПроцедуры

 

Запустите 1С:Предприятие в режиме отладки и проверьте работу множественного подбора (множественный выбор в табличном поле выполняется при нажатой кнопке "Control").

Теперь, если вы удалите комментарий в обработчике события нажатия кнопки "Подбор", то получите вариант "множественного подбора с использованием множественного выбора".




Начало  Назад  Вперед