1С-Предприятие 8.0. Практическое пособие разработчика


Отбор объектов, введенных на основании - часть 2


Запустите 1С:Предприятие в режиме отладки и проверьте работу нового пункта меню.

Получение всех ссылок на все связанные документы для дальнейшего их анализа программными средствами возможно при помощи метода менеджера критерия отбора – Найти() Проиллюстрируем это на примере.

Добавьте в обработчик события "При открытии" формы документа "ОказаниеУслуги" следующие строки:

Процедура ПриОткрытии()

   МассивСсылок = КритерииОтбора.ОказаниеУслуги.Найти(ЭлементыФормы.Клиент.Значение);

   Для Каждого НужнаяСсылка Из МассивСсылок Цикл

       Сообщить(НужнаяСсылка);

   КонецЦикла;

КонецПроцедуры

 

 В оригинале...

Процедура ДействияФормыДокументыКлиента(Кнопка)

   ФормаКритерия = КритерииОтбора.ОказаниеУслуги.ПолучитьФорму();

   ФормаКритерия.Открыть();

   СписокКритерияОтбора = ФормаКритерия.ЭлементыФормы.Список.Значение;

   СписокКритерияОтбора.Отбор.ЗначениеОтбора.Значение = ЭлементыФормы.СправочникСписок.ТекущаяСтрока;

   МассивСсылок = КритерииОтбора.ОказаниеУслуги.Найти(ЭлементыФормы.СправочникСписок.ТекущаяСтрока);

   Для Каждого НужнаяСсылка Из МассивСсылок Цикл

       Сообщить(НужнаяСсылка);

   КонецЦикла;

КонецПроцедуры

 

Запустите 1С:Предприятие в режиме отладки и проверьте вывод списка зависимых документов в окно сообщений. [500]


Предыдущий параграф

Следующая страница

if (window.topicInitScriptAvailable) { HMInitToggle('TOGGLE0186A1','hm:type','dropdown','hm:state','0');HMInitToggle('$TOGGLE0186A1_ICON','hm:type','dropdown','hm:state','0','hm:src0','hmtoggle_plus0.gif','hm:src1','hmtoggle_plus1.gif','onclick','HMToggle(\'toggle\',\'TOGGLE0186A1\',\'\$TOGGLE0186A1_ICON\')');}




Начало  Назад  Вперед