1С-Предприятие 8.0. Практическое пособие разработчика


Оформление строк табличного поля - часть 2


       Если АктуальнаяЦена < 500 Тогда

           ОформлениеСтроки.Ячейки.Цена.ЦветТекста = WEBЦвета.Васильковый;

       КонецЕсли;

 

       //... раздвинуть строку если длинное наименование

       Если СтрДлина(СокрЛП(ДанныеСтроки.Наименование)) > 30 Тогда

           ОформлениеСтроки.Ячейки.Наименование.АвтоВысотаЯчейки = Истина;

           ОформлениеСтроки.Ячейки.Наименование.ВысотаЯчейки = 3;

       КонецЕсли;

   КонецЕсли;

КонецПроцедуры [527]

 

Здесь, в случае вывода элемента справочника, мы анализируем длину его наименования и для наименований более 30 символов устанавливаем автоматическое определение высоты ячейки, ограничивая ее максимальную высоту тремя строками.

Запустим 1С:Предприятие в режиме отладки и посмотрим на результат:


[528]


Предыдущий параграф

Следующая страница




Начало  Назад