1С-Предприятие 8.0. Практическое пособие разработчика


Изменение источника данных табличного поля - часть 2


Сейчас нас устраивает автоматический порядок обхода элементов и поэтому мы создадим обработчик события "ПриОткрытии" формы, и зададим в нем начальное значение нашего переключателя:

Процедура ПриОткрытии()

   ОстаткиМатериалов = "Остатки";

КонецПроцедуры

 

Теперь добавим в форму новый реквизит, который будет являться вторым источником данных для нашего табличного поля. Назовем его "РегистрСписок" и установим его тип РегистрНакопленияСписок.СтоимостьМатериалов:

Укажем его тип РегистрНакопленияСписок.СтоимостьМатериалов.

В заключение создадим процедуру обработки события "При изменении" для кнопки "Остатки материалов":

Процедура ОстаткиМатериаловПриИзменении(Элемент)

   Если ОстаткиМатериалов = "Остатки" Тогда

       ЭлементыФормы.ТабличноеПоле.Данные = "ТабличноеПоле";

   Иначе

       ЭлементыФормы.ТабличноеПоле.Данные = "РегистрСписок";

   КонецЕсли;

   ЭлементыФормы.ТабличноеПоле.СоздатьКолонки();

   ДокументСписокПриАктивизацииСтроки(ЭлементыФормы.ДокументСписок);

КонецПроцедуры [518]

 

В этой процедуре, в зависимости от значения переключателя, мы выбираем тот или иной источник данных для табличного поля. После выбора источника необходимо выполнить метод СоздатьКолонки() для того, чтобы удалить старые колонки табличного поля и загрузить новые колонки из источника данных табличного поля.

Откройте 1С:Предприятие в режиме отладчика и проверьте работу списка документа "ПриходнаяНакладная". [519]




Начало  Назад  Вперед