1С-Предприятие 8.0. Практическое пособие разработчика



              

Создание процедуры расчета записей регистра Начисления - часть 10


               СтруктураНомер.НомерСтроки = ЗаписьРегистра.НомерСтроки;

               ВыборкаРезультата.Сбросить();

               Если ВыборкаРезультата.НайтиСледующий(СтруктураНомер) Тогда

                   ЗаписьРегистра.Результат = ВыборкаРезультата.База * (10/100);

                   Сообщить("Выполнен расчет "+ЗаписьРегистра.Регистратор+" - "+ЗаписьРегистра.ВидРасчета+" - "+ЗаписьРегистра.Сотрудник,);

               КонецЕсли;

           КонецЦикла;

   КонецЕсли;

КонецПроцедуры

Сумму начисленной премии мы рассчитываем как 10% от рассчитанной оплаты по окладу.[355]

Запустим 1С:Предприятие в режиме отладки и проверим правильность работы процедуры расчета.

Отменим проведение документа Начисление сотрудникам №3 и перепроведем документы Начисление сотрудникам №1 и №2. Регистр расчета Начисления должен выглядеть следующим образом:

Гусакову и Деловому начислена премия в размере 10% от суммы начисления по окладу.

Проведем документ Начисление сотрудникам №3, а затем №1 и№2. Состояние регистра изменится следующим образом:

В результате невыхода Гусакова на работу, сумма его оплаты по окладу будет уменьшена и соответствующим образом уменьшится начисленная ему премия. [356]




Содержание  Назад  Вперед