1С-Предприятие 8.0. Практическое пособие разработчика



              

Создание процедуры чтения данных - часть 8


       Возврат;

   КонецПопытки;

   Сообщить("------- Загрузка из " + Строка(ЭтотОбъект) + "-------");

   Сообщить(" - Считывается файл " + ИмяФайла);

   // Загрузить из найденного файла

   //*** Инфраструктура сообщений

   ЧтениеСообщения = ПланыОбмена.СоздатьЧтениеСообщения();

   //читать заголовок сообщения обмена данными - файла XML

   ЧтениеСообщения.НачатьЧтение(ЧтениеXML);

   // Сообщение предназначено не для этого узла

   Если ЧтениеСообщения.Отправитель <> Ссылка Тогда

       ВызватьИсключение "Неверный узел";

   КонецЕсли;

   // Удаляем регистрацию изменений [417]

   // для узла отправителя сообщения

   //*** служба регистрации изменений

   ПланыОбмена.УдалитьРегистрациюИзменений(

       ЧтениеСообщения.Отправитель, ЧтениеСообщения.НомерПринятого);

   // Читаем данные из сообщения

   //*** XML-сериалшация

   Пока ВозможностьЧтенияXML(ЧтениеXML) Цикл

       // Читаем очередное значение

       Данные = ПрочитатьXML(ЧтениеXML);

   КонецЦикла;

   ЧтениеСообщения.ЗакончитьЧтение();

   ЧтениеXML.Закрыть();

   УдалитьФайлы(ИмяФайла);

   Сообщить("------------ Конец загрузки ------------");

КонецПроцедуры

В результате выполнения этого метода переменная "Данные" будет содержать объект 1С:Предприятия, соответствующий данным XML.

Теперь, после того, как объект 1С:Предприятия получен, следует разрешить возможную коллизию:

Процедура ПрочитатьСообщениеСИзменениями() Экспорт

   Каталог = КаталогВременныхФайлов();

   // Сформировать имя файла




Содержание  Назад  Вперед