1С-Предприятие 8.0. Практическое пособие разработчика



              

Создание процедуры чтения данных - часть 5


       СокрЛП(Ссылка.Код) + "_" + СокрЛП(ПланыОбмена.Филиалы.ЭтотУзел().Код) + ".xml";

   Файл = Новый Файл(ИмяФайла);

   Если Не Файл.Существует() Тогда

       Возврат;

   КонецЕсли;

   //*** Чтение документов XML

   // Попытаться открыть файл [414]

   ЧтениеXML = Новый ЧтениеXML;

   Попытка

       ЧтениеXML.ОткрытьФайл(ИмяФайла);

   Исключение

       Сообщить("Невозможно открыть файл обмена данными.");

       Возврат;

   КонецПопытки;

   Сообщить("------- Загрузка из " + Строка(ЭтотОбъект) + "-------");

   Сообщить(" - Считывается файл " + ИмяФайла);

   // Загрузить из найденного файла

   //*** Инфраструктура сообщений

   ЧтениеСообщения = ПланыОбмена.СоздатьЧтениеСообщения();

   //читать заголовок сообщения обмена данными - файла XML

   ЧтениеСообщения.НачатьЧтение(ЧтениеXML);

   // Сообщение предназначено не для этого узла

   Если ЧтениеСообщения.Отправитель <> Ссылка Тогда

       ВызватьИсключение "Неверный узел";

   КонецЕсли;

   // Удаляем регистрацию изменений

   // для узла отправителя сообщения

   //*** служба регистрации изменений

   ПланыОбмена.УдалитьРегистрациюИзменений(

       ЧтениеСообщения.Отправитель, ЧтениеСообщения.НомерПринятого);

   ЧтениеСообщения.ЗакончитьЧтение();

   ЧтениеXML.Закрыть();

   УдалитьФайлы(ИмяФайла);

   Сообщить("------------ Конец загрузки ------------");

КонецПроцедуры

Обратите внимание, что здесь мы обращаемся к службе регистрации изменений и используем метод




Содержание  Назад  Вперед