1С-Предприятие 8.0. Практическое пособие разработчика



              

Создание процедуры чтения данных - часть 12


           ПланыОбмена.ИзменениеЗарегистрировано(ЧтениеСообщения.Отправитель, Данные) Тогда

           Сообщить("- Изменения отклонены");

           Продолжить;

       КонецЕсли;

       // Записать полученные данные

       Данные.ОбменДанными.Отправитель = ЧтениеСообщения.Отправитель;

       Данные.ОбменДанными.Загрузка = Истина;

       Данные.Записать();

   КонецЦикла;

   ЧтениеСообщения.ЗакончитьЧтение();

   ЧтениеXML.Закрыть();

   УдалитьФайлы(ИмяФайла);

   Сообщить("------------ Конец загрузки ------------");

КонецПроцедуры

Перед записью полученного объекта мы устанавливаем у него в параметрах обмена данными узел-отправителя, для того, чтобы система, при записи этого объекта в нашей базе данных, не формировала записи регистрации изменений этого объекта для того узла, от которого мы его только что получили.

Кроме этого, в параметрах обмена данными мы устанавливаем свойство "Загрузка", информирующее систему о том, что запись объекта будет происходить в режиме обновления данных, полученных в результате обмена. Такое указание позволяет системе упростить процедуру записи объекта, отказавшись от ряда стандартных проверок и исключив изменения связанных данных, которые выполняются при, обычной записи.

На этом создание процедуры получения и обработки данных обмена закончено. [421]




Содержание  Назад  Вперед