1С-Предприятие 8.0. Практическое пособие разработчика



              

Создание обработки ОбменДанными


Откроем конфигуратор и создадим новый объект конфигурации Обработка с именем "ОбменДанными". Перейдем на закладку "Прочее" и откроем модуль объекта. Создадим в нем процедуру "ОбменСФилиалами":

Процедура ОбменСФилиалами() Экспорт

ВыборкаУзлов = ПланыОбмена.Филиалы.Выбрать();

   Пока ВыборкаУзлов.Следующий() Цикл

       // Произвести обмен данными со всеми узлами,

       // кроме текущего (ЭтотУзел)

       Если ВыборкаУзлов.Ссылка <> ПланыОбмена.Филиалы.ЭтотУзел() Тогда

           УзелОбъект = ВыборкаУзлов.ПолучитьОбъект();

           // Получить сообщение

           УзелОбъект.ПрочитатьСообщениеСИзменениями();

           // Сформировать сообщение

           УзелОбъект.ЗаписатьСообщениеСИзменениями();

       КонецЕсли;

   КонецЦикла;

КонецПроцедуры

Алгоритм работы этой процедуры заключается в следующем: В цикле мы перебираем узлы, которые содержатся в плане обмена "Филиалы", и для всех узлов, кроме себя самого, производим сначала чтение сообщений, поступивших из других узлов обмена (процедуру [406] "ПрочитатьСообщенияСИзменениями" мы создадим позднее), а затем формируем для них сообщения, предназначенные для передачи и содержащие измененные данные для этого узла (процедура "ЗаписатьСообщениеСИзменениями" также будет создана нами позднее).

Теперь создадим основную форму обработки и в обработчик события нажатия кнопки "Выполнить" – "КнопкаВыполнитьНажатие" вставим вызов процедуры ОбменСФилиалами():

Процедура КнопкаВыполнитьНажатие(Кнопка)

   ОбменСФилиалами();

КонецПроцедуры




Содержание  Назад  Вперед