1С-Предприятие 8.0. Практическое пособие разработчика


Создание движений документа ПриходнаяНакладная - часть 2


       // регистр СтоимостьМатериалов Приход

       Движение = Движения.СтоимостьМатериалов.Добавить();

       Движение.ВидДвижения = ВидДвиженияНакопления.Приход; [304]

       Движение.Период = Дата;

       Движение.Материал = ТекСтрокаМатериалы.Материал;

       Движение.Стоимость = ТекСтрокаМатериалы.Сумма;

   КонецЦикла;

   Для Каждого ТекСтрокаМатериалы Из Материалы Цикл

       // регистр Управленческий

       Движение = Движения.Управленческий.Добавить();

       Движение.СчетДт = ПланыСчетов.Основной.Товары;

       Движение.СчетКт = ПланыСчетов.Основной.РасчетыСПоставщиками;

       Движение.Период = Дата;

       Движение.Сумма = ТекСтрокаМатериалы.Сумма;

       Движение.КоличествоДт = ТекСтрокаМатериалы.Количество;

       Движение.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.Материалы] = ТекСтрокаМатериалы.Материал;

   КонецЦикла;

   // записываем движения регистров

   Движения.ОстаткиМатериалов.Записать();

   Движения.СтоимостьМатериалов.Записать();

   Движения.Управленческий.Записать();

   //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

 

Платформа сформировала уже знакомые нам три цикла обхода табличной части документа (для каждого регистра свой цикл). В первых двух циклах для нас нет ничего нового. В последнем, по большому счету, тоже – движения формируются таким же образом, как и для регистра накопления. Интерес для нас представляет только последняя строчка цикла, в которой присваивается значение субконто дебета.

Дело в том, что количество субконто как по дебету, так и по кредиту у каждой записи движения регистра будет различное, в зависимости от того, как определены счета в используемом плане счетов. Поэтому для каждой записи движения регистра бухгалтерии платформа хранит две коллекции значений: коллекцию субконто дебета и коллекцию субконто кредита. Каждая из этих коллекций содержит ровно столько элементов, сколько указано использовать видов субконто для соответствующего счета (дебета или кредита) в плане счетов. Обратиться к элементу коллекции можно, указав в квадратных скобках ссылку на соответствующий вид характеристик, либо указав через точку имя предопределенного вида характеристик. [305]




Начало  Назад  Вперед



Книжный магазин