1С-Предприятие 8.0. Практическое пособие разработчика



              

Программный обмен в распределенной информационной базе - часть 4


       ПланыОбмена.ПрочитатьИзменения(ЧтениеСообщения);

       // Закончить чтение сообщения и чтение XML

       ЧтениеСообщения.ЗакончитьЧтение();

       ЧтениеXML.Закрыть();

       Предупреждение("Чтение изменений завершено.");

   КонецЕсли;

КонецПроцедуры

В начале процедуры мы снова вызываем диалог ввода имени файла, который будет прочитан, и создаем объект ЧтениеXML для работы с этим файлом. Затем создаем объект ЧтениеСообщенияОбмена для чтения сообщения, содержащегося в указанном файле. Затем методом ПрочитатьИзменения() объекта ПланыОбменаМенеджер мы читаем полученное сообщение. В заключение процедуры мы завершаем чтение сообщения обмена и закрываем файл.

Проверить работу нашей обработки можно на примере, аналогичном приведенному в разделе универсального обмена Данными.[437]

Следует лишь сделать несколько заключительных замечаний.

При использовании механизма распределенных информационных баз становятся доступными четыре события объект ПланОбменаОбъект, которые позволяют управлять отправкой \ приемом данных на уровне отдельных элементов данных:

·ПриОтправкеДанныхГлавному(),
·ПриОтправкеДанныхПодчиненному(),
·ПриПолученииДанныхОтГлавного(),
·ПриПолученииДанныхОтПодчиненного().

Эти события будут вызываться для каждого элемента данных включаемого в сообщение. Работу этих событий можно увидеть добавив в модуль объекта План обмена следующий текст:

Процедура ПриОтправкеДанныхГлавному(ЭлементДанных, ОтправкаЭлемента)

   Сообщить("ПриОтправкеДанныхГлавному "+ЭлементДанных);

КонецПроцедуры

Процедура ПриОтправкеДанныхПодчиненному(ЭлементДанных, ОтправкаЭлемента)

   Сообщить("ПриОтправкеДанныхПодчиненному "+ЭлементДанных);

КонецПроцедуры

Процедура ПриПолученииДанныхОтГлавного(ЭлементДанных, ПолучениеЭлемента, ОтправкаНазад)




Содержание  Назад  Вперед