1С-Предприятие 8.0. Практическое пособие разработчика


Отчет ВыручкаМастеров - часть 5


Запустим 1С:Предприятие в режиме отладки и выполним отчет "ВыручкаМастеров" за период с 20.03.2004 по 20.04.2004.

В целях экономии неинформативного пространства книги, мы не будем приводить результат работы отчета, но на словах объясним, что результат отчета будет содержать по 32 строки дат для каждого сотрудника.

Очевидно, что такой внешний вид отчета абсолютно "нечитабелен", поэтому мы снова вернемся к модулю отчета и внесем небольшие уточнения в алгоритм вывода областей табличного документа:

   Пока ВыборкаМастер.Следующий() Цикл

       ОбластьМастер.Параметры.Заполнить(ВыборкаМастер);

       ТабДок.Вывести(ОбластьМастер, ВыборкаМастер.Уровень());

 

       ВыборкаПериод = ВыборкаМастер.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "Период","Все");

 

       Пока ВыборкаПериод.Следующий() Цикл

           ОбластьПериод.Параметры.Заполнить(ВыборкаПериод);

           ТабДок.Вывести(ОбластьПериод, ВыборкаПериод.Уровень(),,Ложь);

 

           ВыборкаДетали = ВыборкаПериод.Выбрать();

 

           Пока ВыборкаДетали.Следующий() Цикл

               ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетали);

               ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетали.Уровень());

           КонецЦикла;

       КонецЦикла;

   КонецЦикла;

 

Смысл внесенных нами изменений заключается в том, что при выводе областей детальных записей и периода, мы сворачиваем группировки, которые по умолчанию выводятся развернутыми.

Запустим 1С:Предприятие в режиме отладки и снова выполним отчет "ВыручкаМастеров" за период с 20.03.2004 по 20.04.2004. [189]

На этот раз результат выглядит гораздо лучше:

Итак, на примере этого отчета мы продемонстрировали, как строить многоуровневые группировки в запросе, как обходить все даты в выбранном периоде и как управлять состоянием группировок в табличном документе. [190]




Начало  Назад  Вперед



Книжный магазин