1С-Предприятие 8.0. Практическое пособие разработчика


Отчет ВыручкаМастеров - часть 4


   |    Период ПЕРИОДАМИ(День, &ДатаНачала, &ДатаОкончания)";

 

Такая запись говорит о том, что итоги должны быть, рассчитаны периодами равными дню, в интервале дат, задаваемом параметрами "ДатаНачала" и "ДатаОкончания".

И для того, чтобы все эти итоги попали в итоговый табличный документ, нам нужно будет уточнить порядок вывода итогов в выборке результата запроса:

   ВыборкаМастер = ВыборкаОбщийИтог.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

 

   Пока ВыборкаМастер.Следующий() Цикл

       ОбластьМастер.Параметры.Заполнить(ВыборкаМастер);

       ТабДок.Вывести(ОбластьМастер, ВыборкаМастер.Уровень());

 

       ВыборкаПериод = ВыборкаМастер.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "Период","Все");

 

       Пока ВыборкаПериод.Следующий() Цикл

           ОбластьПериод.Параметры.Заполнить(ВыборкаПериод);

           ТабДок.Вывести(ОбластьПериод, ВыборкаПериод.Уровень());

 

           ВыборкаДетали = ВыборкаПериод.Выбрать();

 

           Пока ВыборкаДетали.Следующий() Цикл

               ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетали);

               ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетали.Уровень());

           КонецЦикла;

       КонецЦикла;

   КонецЦикла; [188]

 

Смысл внесенных нами уточнений заключается в том, что теперь при формировании выборки по группировке "Период" будут выбираться все имеющиеся значения группировок.




Начало  Назад  Вперед



Книжный магазин