Учебник по 1С


Синтаксис языка 1С - часть 2


КонецЦикла;

Оператор Продолжить передает управление в начало цикла.

Пока <условие> Цикл

Если <условие> Тогда

.........Прервать;

КонецЕсли;

КонецЦикла;

Оператор Прервать производит досрочный выход из цикла. Управление передается на операторы после цикла.

Перем Сотр;

Явное объявление переменной.

Номер = 1;

Переменные можно не объявлять явно. При первом присвоении значения создается новая переменная.

ФИО = Фамилия + " " + Имя + " " + Отчество;

Сложение строк (конкатенация)

НекаяДата = '01.01.2002';

Переменная, которая хранит дату.

Перем глТекущийПользователь Экспорт;

Объявление глобальной переменной в Глобальном модуле. Такие переменные доступны в любом месте конфигурации.

Попытка

а = 10 / 0;

Исключение

Предупреждение("Деление на ноль!");

КонецПопытки;

Обработка исключительных ситуаций.

Если во время выполнения операторов между словами Попытка и Исключение произошла ошибка, то управление передается на операторы между словами Исключение и КонецПопытки

Если ошибки не было, то управление передается на операторы после слова КонецПопытки.

//это комментарий

Так оформляются комментарии.

СпрСотр.ВыбратьЭлементы();

Вызов метода объекта производится как обычно, через точку.

<




Начало  Назад  Вперед