Учебник по 1С


Примеры


//1-й вариант: выборка по объекту

История = СоздатьОбъект("Периодический");

История.ИспользоватьОбъект("Оклад",ВыбСотрудник);

История.ВыбратьЗначения(ДатаНач,ДатаКон);

История.ОбратныйПорядок(1);

Пока История.ПолучитьЗначение()=1 Цикл

ОчерДата = История.ДатаЗнач;

ОчерДата = История.Значение;

Док = История.ТекущийДокумент();

КонецЦикла;


//2-й вариант: выборка по документу

История = СоздатьОбъект("Периодический");

История.ВыбратьПоДокументу(ДокКадровоеПеремещениеСписком);

Пока История.ПолучитьЗначение()=1 Цикл

ТекОбъект = История.ТекущийОбъект();

Если ТипЗначенияСтр(ТекОбъект) = "Справочник" Тогда

Если ТекОбъект.Вид()= "Сотрудники" Тогда

ТекСотр = ТекОбъект;

ТекРеквизит = История.ТекущийРеквизит();

ОчерДата = История.ДатаЗнач;

ОчерЗначение = История.Значение;

КонецЕсли;

КонецЕсли;

КонецЦикла;

//поиск

ЗначениеНаДату

НайтиЗначение

//корректировка

НазначитьТип

Записать

Удалить





Начало  Назад  Вперед



Книжный магазин