Учебник по 1С


Примеры


Пример

//переместить все текстовые файлы (*.txt) из каталога информационной базы в каталог TXT.

ФС.УстТекКаталог(КаталогИБ());

ИмяФайла = "";

ИмяФайла = ФС.НайтиПервыйФайл("*.txt");

Если ИмяФайла <> "" Тогда

.... ФС.СоздатьКаталог("TXT");

.....ФС.КопироватьФайл(ИмяФайла,ФС.ТекКаталог() + "TXT" + ИмяФайла);

.....ФС.УдалитьФайл(ИмяФайла);


Пока 1=1 Цикл

ИмяФайла = " ";

.....ИмяФайла = ФС.НайтиСледующийФайл()

Если ИмяФайла <> "" Тогда

.....ФС.КопироватьФайл(ИмяФайла,ФС.ТекКаталог() + "TXT" + ИмяФайла);

.....ФС.УдалитьФайл(ИмяФайла);

Иначе

..... Прервать;

КонецЕсли;

КонецЦикла;


Пример

//выбрать файл с фотографией сотрудника

ИмяФайла = "";

ИмяКаталога = КаталогИБ();

Если ФС.ВыбратьФайлКартинки(0,ИмяФайла,ИмяКаталога,"Укажите файл с фотографией:",,20)=1 Тогда

ВремКартинка = СоздатьОбъект("Картинка");

ВремКартинка.Загрузить(ИмяКаталога + ИмяФайла);

КартинкаНаФорме.УстановитьКартинку(ВремКартинка);

КонецЕсли;





Начало  Назад  Вперед



Книжный магазин