Учебник по 1С


Отчет "Остатки"


Экранная форма диалога отчета выглядит следующим образом:

Модуль отчета:

Процедура Сформировать()

Запрос = СоздатьОбъект("Запрос");

ТекстЗапроса = "

|Кошелек = Регистр.Кошельки.Кошелек;

|Участник = Регистр.Кошельки.Кошелек.Участник;

|Сумма = Регистр.Кошельки.Сумма;

|Группировка Кошелек;

|Функция СуммаВКошельке = КонОст(Сумма);

|Условие(Кошелек в ВыбрКошелек);

|Условие(Участник в ВыбрУчастник);

|";


Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда

.......Возврат;

КонецЕсли;


Таб = СоздатьОбъект("Таблица");


Таб.ВывестиСекцию("Все<");


Пока Запрос.Группировка(1) = 1 Цикл

....... Таб.ВывестиСекцию("Кошелек");

КонецЦикла;


Таб.ВывестиСекцию("Все>");

Таб.Показать();

КонецПроцедуры

Пример работы отчета:




Начало  Назад  Вперед



Книжный магазин