Учебник по 1С


Информация о текущем элементе


Если справочник многоуровневый, то будет полезным применение следующих методов и атрибутов, которые позволяют получить информацию о текущем элементе справочника:

Метод / атрибут

Описание

Уровень()

Этот метод возвращает уровень текущего элемента. Например, для сотрудника, который находится в группе Работающие, мы получим число 2.

Пример, вывод иерархического справочника в виде дерева:

СпрСотр = СоздатьОбъект("Справочник.Сотрудники");

СпрСотр.ВыбратьЭлементы();

Пока СпрСотр.ПолучитьЭлементы()=1 Цикл

//вывести отступ в соответствии с глубиной вложенности элемента

Для Ном=1 По СпрСотр.Уровень() Цикл

.....Сообщить(".....");

КонецЦикла;

Сообщить(СпрСотр.Наименование);

КонецЦикла;

ЭтоГруппа()

Этот метод возвращает 1, если текущий элемент справочника является группой, или 0 если группой не является.

Пример, вывод сотрудников (группы не выводятся):

СпрСотр = СоздатьОбъект("Справочник.Сотрудники");

СпрСотр.ВыбратьЭлементы();

Пока СпрСотр.ПолучитьЭлементы()=1 Цикл

Если СпрСотр.ЭтоГруппа()=1 Тогда

......Продолжить; //группы пропускаем, перейти в начало цикла

КонецЕсли;

Сообщить(СпрСотр.Наименование);

КонецЦикла;

ПринадлежитГруппе(...)

Метод проверяет, принадлежит ли указанной группе текущий элемент справочника (независимо от того, на каком нижележащем уровне он находится).

Возвращает: 1 - если элемент принадлежит указанной группе , 0 - если нет.

Пример, вывод товаров, принадлежащих к группе Спиртное, независимо от того входят ли они в подгруппы Шампанское, Пиво, Водка, Вино и т.д.:

СпрТовары = СоздатьОбъект("Справочник.Товары");

СпрТовары.ВыбратьЭлементы();

Пока СпрТовары.ПолучитьЭлементы()=1 Цикл

Если СпрТовары.ПринадлежитГруппе(грпСпиртное)=1 Тогда

.....Сообщить(СпрТовары.Наименование);

КонецЕсли;

КонецЦикла;

атрибут Родитель

Этот атрибут содержит родителя текущего элемента справочника, т.е. группу, в которой находится текущий элемент. Доступен для чтения и записи.

Пример, перенос всех товаров из группы Спиртное в группу Распродажа:




Начало  Назад  Вперед



Книжный магазин